Краткая инструкция по работе с персональным навигатором Lks Navigator v.1.04


Назначение программы

Программа Lks Navigator предназначена для GPS навигации с применением карт формата lsm, а также с использованием спутниковых снимков с серверов Google, MS Virtual Earth. В последнем случае нужные для навигации территории можно загрузить через интернет, упаковать в кэш и использовать в дальнейшем без подключения к интернету. Есть возможность переключения между спутниковым снимком и картой формата lsm, при этом оба вида навигации синхронизированы друг с другом, т.е. перемещение карты приводит к синхронному перемещению спутникового снимка и наоборот. Программа работает с любыми GPS приемниками работающими по протоколу NMEA-0183. Есть возможность сохранять маршруты движения (точки маршрута сохраняются по определенным критериям), кроме того с каждой точкой маршрута можно автоматически связывать изображения полученные с Web камер, подключенных к программе.
Программа Lks Navigator позволяет подключать расширения, разработанные в редакторе Lks ScriptEdit (см. руководство по созданию расширений), которыми можно наращивать функциональность программы (например, отображать свою информацию из баз данных, работать с маршрутами и т.д.). Кроме того программа Lks Navigator включает в себя встроенную исполняющую среду Lks CityMap, которая исполняет приложение, находящееся внутри открытой карты, так, как оно бы выполнялось при открытии в исполняющей среде Lks cityMap.

Подключение к кэшу

При первом запуске программы нужно выбрать кэш для спутниковых снимков и, при необходимости, рабочую карту. Для этого служат пункты главного меню Файл -> Открыть кэш и Файл -> Открыть Карту соответственно. Если при открытии кэша указать несуществующий файл, то будет создан пустой кэш по указанному пути. В комплекте поставки программы Lks Navigatorесть кеш, содержащий 5 первых уровней, который можно использовать как базовый для дальнейшего использования. При последующих запусках программы будет автоматически открываться кэш и карта, которые были открыта при предыдущем сеансе работы.

При запуске программы также происходит позиционирование карты и спутникового снимка к позиции, которая была на момент закрытия программы.

Работа с картой

Карта отображается на вкладке Карта главного окна программы. Эта вкладка автоматически активируется при открытии новой карты.



Чтобы перемещать карту в окне нужно нажать правую кнопку мыши и удерживая ее переместить мышь в нужном направлении. Карта будет перемещаться в окне просмотра.
Для изменеия масштаба отображения используется панель масштабирования. Можно выбрать нужный масштаб из выпадающего списка или нажатием кнопок "Увеличить масштаб", "Уменьшить масштаб" или "Масштаб 1:1".
Нужную страницу карты можно выбрать в выпадающем списке на панели инструментов вкладки с картой.

Работа со спутниковым снимком

Спутниковый снимок отображается на вкладке Спутник главного окна программы.
Для перемещения спутникового снимка в окне просмотра нужно нажати левую кнопку мыши и, удерживая ее переместить мышь в нужном направлении. Отпускать кнопку мыши нужно в пределах окна просмотра, после чего произойдет перерисовка изображения. Если подвести указатель мыши в правый верхний угол окна просмотра, то появится номер текущего уровня просмотра (от 1 до 20). Для изменения уровеня (масштаба отображения) служат комбинации клавиш: Alt+I (или +) - увеличение уровня и Alt+O (или -) - уменьшение уровня. Через 5 секунд отображение номера текущего уровня в углу окна исчезает автоматически. В нижнем левом углу окна просмотра отображаются координаты точки в которой находится указатель мыши. В нижнем правом углу показана масштабная линейка. Для измерения расстояния нужно в левом верхнем углу окна просмотря нажать кнопку Линейка. Далее в окне просмотра нужно правой кнопкой мыши нанести узловые точки измеряемой траектории. Траектория отрисовывается поверх снимка, а ее длина паказывается в верху окна. Что бы изменить размерность измеренного расстояния нужно кликнить мышью по размерности. Для сброса траектории нужно нажать кнопку Сброс.

Использование базы населенных пунктов

Программа Lks Navigator может выводить названия населенных пунктор на спутниковый снимок. Для использования этой возможности нужно в один каталог с используемым кэшем положить базу данных населенных пунктов ( WORLD.GDB ). Кроме того на компьютере должен быть установлен сервер и клиент FireBird (его можно скачать на странице загрузки). Если все вышеуказанные условия соблюдены, то после открытия кэша производится подключение к базе населенных пунктов, и данные из нее отображаются на спутниковом снимке как показано на вышеприведенном изображении.
Для создания пустой базы данных можно воспользоваться sql-скриптом . Для правильной работы скрипта нужно оба файла из архива положить в корень диска c:\ и выполнить коммандный файл Create_world_db.bat. В корне диска c:\ будет создана база данных world.gdb, которую нужно перенести в папку с файлом кэша. База содержит 3 таблицы: COUNTRIES (страны), REGIONS (регионы) и CITY (города). Для отображения названий населенных пунктов на спутниковом снимке в текущей версии программы достаточно в таблицу CITY занести названия населенных пунктов (в поле TRANSLITNAME) и координаты (в поля LAT, LON, положительные значения соответствуют северной широте и восточной долготе).
Базу данных с названиями населенных пунктов России можно скачать здесь.

Поиск объектов

В программе Lks Navigator организован поиск объектов по карте и базе данных. Для открытия окна поиска нужно в главном меню выбрать пункт Просмотр -> Найти или нажать CTRL+F
Если активна вкладка Карта то откроется окно поиска по карте

На вкладке Критерии поиска нужно указать искомое слово (или часть слова), по которому будет производиться поиск. Если производится многоуровневый поиск, то критерии поиска для каждого уровня задаются в отдельной строке, поиск начинается с нижней строки. Например, если в критерий поиска поместить две строки:
ул. Центральныя
35
то будут найдены все объекты с именем 35, и из них в результат поиска попадут объекты, имеищие владельца ул. Центральная).
В выпадающих списках Слои карты и Уровни коммуникаций нужно выбрать слой, на котором будет производиться поиск. Если выбрать значение Все слои и Все уровни, то поиск будет проводиться по всем слоям карты и по всем уровням коммуникаций.
После нажатия кнопки Найти начнется поиск и по его завершении будет сформирован список найденных объектов на вкладке Результаты поиска. Если этот список пуст, значит не найдено ни одного объекта, удовлетворяющего заданным критериям. Если в списке есть найденные объекты, то перейти к нужному объекту можно двойным щелчком мыши по объекту, при этом карта автоматически сфокусируется на этот объект.

Если открыта вкладка Спутник и есть база данных населенных пунктов, то при активации поиска откроется окно поиска по базе данных: В поле поиска нужно ввести название населенного пункта (Название нужно вводить с учетом регистра) и нажать Enter. Найденные объекты будут показаны в списке результатов поиска. Чтобы перейти к нужному объекту нужно выполнить двойной клик мышью по нужному объекту.

Работа с закладками

Пользовательские закладки находятся на левой боковой панели, в верхней ее части. Закладки организованы в виде древовидной структуры, состоящей из групп и непосредственно закладок. Любая руппа может содержать как вложенные группы, так и закладки.
Для создания новой группы нужно в дереве закладок выбрать родительскую группу и в контекстном меню выбрать пункт Добавить группу.

Для создания закладки нужно в дереве закладок выбрать родительскую группу и в контекстном меню выбрать пункт Добавить закладку. После этого нужно кликнуть правой кнопкой мыши в нужном месте спутникового снимка.
Если запущен опрос GPS -приемника (см. использование GPS - приемника), то выбрав в контекстном меню группы пункт Закладка в текущей позиции, можно добавить закладку с координатами текущей позиции маркета GPS.
Для перехода к нужной закладке нужно двойным кликом мыши кликнуть по ней. спутниковый снимок автоматически сместится в позицию закладки, а место на нем будет отмечено флажком.

Использование GPS приемника

Программа Lks Navigator поддерживает все GPS приемники, работающие по протоколу NMEA-0183. Для активации GPS приемника нужно открыть панель GPS, выбрав в главном меню пункт Вид -> Панель GPS или нажав Alt+G



На вкладке Настройки нужно задать параметры GPS приемника, после чего перейти на вкладку Информация и нажать кнопку Запустить опрос. Если установить параметр Следить за положением, то спутниковый снимок и карта будут автоматически перемещаться в окне просмотра, таким образом, чтобы маркер GPS позиции оставался в поле зрения.
В нижней части вкладки отображается информация о видимых спутниках.

Запись маршрута движения

Таблица маршрутов находится на левой боковой панели в нижней части.
Чтобы начать запись маршрута нужно запустить опрос GPS приемника, как сказано выше. Затем на панели маршрутов нажать кнопку Добавить маршрут, выделить созданный маршрут и нажать кнопку Начать запись маршрута. После этого к выбранному маршруту будут добавляться точки в соответствии с критериями, указанными на панели GPS. Запись маршрута будет продолжаться пока не будет нажата кнопка Осиановить запись маршрута или пока не будет остановлен опрос GPS приемника. Записываемый маршруа автоматически прорисовывается на спутниковом снимке и карте.
Записанные маршруты можно сохранить кнопкой Сохранить маршруты и в последствии загрузить их для просмотра кнопкой Загрузить маршруты.
Программа также позволяет загружать треки, сохраненные программой Data Logger PC Utility, поставляемой с GPS даталоггерами GlobalSat.
Все маршруты, находящиеся в таблице маршрутов автоматически отображаются на спутниковом снимке и на карте. Для того, чтобы перейти к нужному маршруту, нужно выполнить по нему двойной клик мышью, при этом космический снимок сместится к этому маршруту и он будет выделен синим цветом. В нижнемй части окна просмотра будет показан график высот и скоростей маршрута. Маркер на графике можно перемещать, при этом соответствующая точка будет показана на снимке синим флажко
Информацию по точкам выбранного маршрута можно просмотреть в табличном виде на вкладке Маршрут главного окна программы.


Использование контрольных точек

В программе Lks Navigator можно задать таблицу контрольных точек. При приближении и удалении к этим точкам на заданную величину будет выдаваться заданный звуковой сигнал.
Таблица активных контрольных точек находится на вкладке Контрольные точки главного окна программы.

Для добавление точек в эту таблицу нужно в дереве закладок выбрать закладку или группу закладок и в контекстном меню выбрать пункт Добавить в контрольные точки. При выборе группы добавляются все закладки этой группы и всех вложенных групп.
В таблице контрольных точек отображается состояние всех точек в графе Состояние. Для точек, находящихся вне зоны сближения в этой графе ничего нет, а для точек нажодящихся в зоне сближения Приближение или Удаление. 
Настройка радиуса контрольной зоны и звуковых файлов оповещения производится в окне настроек программы..

Загрузка спутниковых снимков

В комплекте с программой Lks Navigator поставляется программа GLoad для загрузки спутниковых снимков в кэш. Для запуска загрузки нужной территории нужно выделить ее  на спутниковом снимке (выделение производится перемещением мыши, удерживая правую кнопку). Далее в главном меню выбрать Файл -> Кэш -> Загрузить в кэш.

В открывшемся окне нушно указать необходимые уровни и нажать кнопку Ок (Выбор сервера и настройка параметров подключения производится в окне настроек программы Navigator). Далее программа определит каких участков выбранной территории еще нет в кэше и сформирует файл задания на закачку для программы GLoad. Программа GLoad не имеет оконного интерфейса. Все результаты ее работы отображаются во всплывающей подсказке на значке в области уведомлений, а управление осуществляется по http протоколу специальными коммандами из программы Navigator. Программа GLoad загружает данные во временные кэш, находящийся в папке с рабочим кэшем. Временный кэш состоит из папок с именами от 1 до 20, содержащими данные по соответствующим уровням. Для добавления данных из временного кэша в рабочий нужно выбрать в главном меню программы Navigator пункт Файл -> Кэш -> Упаковать Кэш. После упаковки временный кэш можно удалить.
Рабочий и временный кэш можно использовать в программах Lks MapEdit и Lks ScriptEdit.


lkssupport@bk.ru