Краткая инструкция по работе с программой Lks MapView v.1.03


Открытие карты

Для загрузки карты в окно программы MapView нужно выбрать пункт главного меню Файл-> Открыть карту. Выбранная карта загрузится и отобразится в окне программы и сфокусируется на геометрический центр карты (т.е. в точку, равноудаленную от самых крайних элементов карты).

Навигация по карте

Чтобы перемещать карту в окне нужно нажать правую кнопку мыши и удерживая ее переместить мышь в нужном направлении. Карта будет перемещаться в окне просмотра.
Для изменеия масштаба отображения используется панель масштабирования. Можно выбрать нужный масштаб из выпадающего списка или нажатием кнопок "Увеличить масштаб", "Уменьшить масштаб" или "Масштаб 1:1" Переместиться к нужной точке карты можно задав координаты этой точки в полях "X" и"Y" на панели инструментов.
Пункт главного меню Страницысодержит список страниц открытой карты. При выборе в этом пункте нужной страницы, происходит ее отображение в окне.

Поиск объекта карты

Для поиска объекта карты по его названию нужно выбрать в главном меню пункт Файл->Поиск объекта или воспользоваться комбинацией клавиш CTRL+F. При этом будет выведено окно поиска:

На вкладке Критерии поиска нужно указать искомое слово (или часть слова), по которому будет производиться поиск. Если производится многоуровневый поиск, то критерии поиска для каждого уровня задаются в отдельной строке, поиск начинается с нижней строки. Например, если в критерий поиска поместить две строки:
ул. Центральныя
35
то будут найдены все объекты с именем 35, и из них в результат поиска попадут объекты, имеищие владельца ул. Центральная).
В выпадающих списках Слои карты и Уровни коммуникаций нужно выбрать слой, на котором будет производиться поиск. Если выбрать значение Все слои и Все уровни, то поиск будет проводиться по всем слоям карты и по всем уровням коммуникаций.
После нажатия кнопки Найти начнется поиск и по его завершении будет сформирован список найденных объектов на вкладке Результаты поиска. Если этот список пуст, значит не найдено ни одного объекта, удовлетворяющего заданным критериям. Если в списке есть найденные объекты, то перейти к нужному объекту можно двойным щелчком мыши по объекту, при этом карта автоматически сфокусируется на этот объект.

Инспектор слоев

Инспектор слоев отображается/скрывается пунктом "Слои" в меню "Вид" или кнопкой F9.



В инспекторе слоев есть две вкладки. Первая отображает слои карты, а вторая слои коммуникаций. При двойном щелчке мышью происходит скрытие/отображение слоя.

Наложение маршрутов на карту

Просмотрщик MapView позволяет отображать маршруты движения на загруженной карте. Для работы с маршрутами нужно выбрать пункт главного меню Маршруты->Таблица маршрутов.

Для ручного добавления маршрута нужно в окне маршрутов нажать кнопку Начать маршрути задать параметры маршрута. После этого, пока не будет нажата кнопка Закрыть маршрут каждое нажатие левой кнопки мыши на карте будет добавлять в конец маршрута новую точку. Удалить последнюю точку маршрута можно кнопкой Удалить последнюю точку, а маршрут целиком кнопкой Удальть маршрут
Изменить цвет, толщину и название маршрута можно через диалог, вызываемый двойным щелчком мыши по соответствующему полю таблицы маршрутов.
Сохраненить таблицу маршрутов в файл можно кнопкой Сохранить маршруты, а загрузить из файла кнопкой Загрузить маршруты. При этом следует учитывать, что таблица маршрутов для каждой страницы карты своя и операции сохранения/загрузки работают с текущей страницей.
Доступ к маршрутам возможен из других программ посредством COM интерфейсов, описанных в разделе Инструкция разработчика.

Запись маршрутов с GPS

Для записи маршрута с GPS  нужно выбрать пункт главного меню Маршруты->Таблица маршрутов и переити на вкладку GPS.

На этой вкладке есть еще две вкладки: Настройки и информация. На вкладке настройки нужно задать параметры соединения с GPS-приемником, после этого перейти на вкладку информация и нажать кнопку Запустить опрос. В нижней части окна будут показаны все видимые спутники. Можно также указать критерии добавления точки к маршруту. Если установить Следить за положением, то карта будет автоматически перемещаться в окне просмотра, таким образом, что маркер текущего положения будет всегда виден в окне карты.

Для начала записи маршрута нужно перейти на вкладку таблицамаршрутов и нажать кнопку Начать маршрут. После этого, пока не будет нажата кнопка Закрыть маршрут или не будет остановлен опрос GPS приемника, к маршруту будут добавляться точки, удовлетворяющие критериям указанным на вкладке GPS.


lkssupport@bk.ru